HELP

Viewer
for
「情報機器と情報社会のしくみ素材集」
Version 2.2

情報機器と情報社会のしくみ素材集」という、非常に優れた静止画・動画の素材集が公開されています。それぞれが工夫して使うという主旨だと思いますが、素材集として、コンテンツの集合になっています。関連付けてみることが出来たらなあと思い、閲覧ソフトを作りました。
2002年6月にVersion 2.1を公開しました。その後「素材集」の改定が行われ、Viewer　Softが対応してない画像が増えてきました。そこでVersion 2.2として最新の画像に対応するように改定しました。
Version2.2では2003年12月20日現在で公開されている画像ファイルをを閲覧できるようにしました。


セットアップ

 | セットアップ
a | ホームページからセットアップファイルをダウンロードします。
b | このファイルはLｚｈ形式で圧縮してありますから、適当な解凍ソフトで解凍します。
c | 解凍したフォルダーを開くと、「ＳＥＴＵＰ．ｅｘｅ」という名のファイルがありますから、これをダブルクリックします。セットアッププログラムが起動します。
d | セットアッププログラムの案内にしたがって、セットアップを完了してください。
e | スタートメニューの中に、『情報機器と情報社会』が登録されています。
 | WindowsXPにインストールしようとすると、右の図のような表示が出て、インストールが出来ない場合があります。ユーザー名が日本語（全角文字）の場合にそうなるようです。 対策で手っ取り早いのは次の方法です。 スタートメニューからコントロールパネルを開いて、ユーザーアカウントを追加する。そのときユーザー名を（直接入力：半角文字）にする。いったんログアウトして、新たなユーサー名でログインする。そこで、インストールをしてみてください。

トップ アイコン トップページへもどる

直線上に配置


画像のダウンロード

このソフトは、「情報機器と情報社会のしくみ素材集」で公開されている画像を閲覧するためのソフトです。必要なファイルは下記のＵＲＬからダウンロードしてください。

http://www.kayoo.org/home/mext/joho-kiki/

この閲覧ソフトで使う画像ファイルは194ファイルです。

ダウンロードしたならば、適当なフォルダに一括して保存します。保存場所は、ハードディスクの中でも、CD-Rでも、ネットワーク上のドライブでもかまいません。フォルダー名も適当につけてかまいません。ただし、画像のファイル名は変更しないでください。

画像ファイルは数百、ファイル容量も数百MBになりますので、ファイルのダウンロードは大変手間のかかる作業になります。そこでまとめてダウンロードするツールをギジュツメーリングリストでGetHTMLというフリーソフトを紹介していただきました。

http://hp.vector.co.jp/authors/VA014425/gethtmlw.html

今回、このViewerで必要なファイルだけをダウンロードしてひとつのフォルダに格納することのできるダウンロードツールをつくり公開しています。

ダウンロードツールの使用方法

このソフトですべての画像を見るには、使用するパソコンに、「Windows　Media player　Ver.7.1」以上がインストールされている必要があります。Windows　Media player　は以下のURLからダウンロードできます。

http://www.microsoft.com/japan/windows/windowsmedia/download/default.asp

トップ アイコン トップページへもどる

直線上に配置


ダウンロードツール

ダウンロードツールの使い方

ダウンロードツールをセットアップしてプログラムを起動させると、次のような画面が現れます。

まず第一にダウンロードした画像を収納するフォルダを指定します。左側のディレクトリ・ツリーでフォルダを選びます。するとフォルダのところにそのフォルダにあるファイルが表示されています。

次にパソコンがインターネットに接続されていることを確認します。
これで準備完了。後は「ダウンロード開始」ボタンをクリックすると、自動的にファイルを次々とダウンロードしていきます。

全体で450MBになりますので、少なくとも500MBの画像ファイルが収納できるディスク・フォルダを用意しましょう。
パソコンの環境によっては数時間の時間が必要になる場合があります。

ダウンロードが終わったら、指定したフォルダを確認してみましょう。194ファイルがダウンロードされていればOKです。

トップ アイコン トップページへもどる

直線上に配置


ソフトの使い方

 | ソフトの使い方
a. | スタートメニューのプログラムから『Viewer for 「IT」』を選択して、クリックします。
図1．起動画面
b. | 図1は起動画面です。Okボタンをクリックします。
図2. 「画像データ保管場所確認」画面
c. | 一番初めに起動したときだけ、図2の「画像データ保管場所確認」画面が現れます。「画像データ保管場所確認」ボタンをクリックします。
図3. ダイアログボックス
d. | 画像データの保管場所を探すダイアログボックスが開きます。画像データを保管してあるドライブ・フォルダーを探してください。保管場所にたどり着くと、「1101-Ａ」だけが表示されます。これをクリックして、「開く」ボタンをクリックします。
e. | そうすると、「画像データ保管場所確認」画面にパス名が表示されます。
f. | 画像の保管方法を確認します。ダウンロードした画像ファイルを一括して同じフォルダに保存している場合は「一括」を選びます。GETHTMLのようなダウンロードツールを使って「素材集」のWEBSITEにあるフォルダ構成のまま保存している場合は「WEBのツリー構造」を選びます。 「画像データ保管場所確認」画面は、最初だけ現れて、２回目からは現れません。データが削除されている場合、またはネットワークが切断されて、プログラムがデータにアクセスできない場合に現れます。 データの保管場所を確認して、もう一度パス名を取得してください。
g. | 画像ファイルの保管場所と保管方法の確認ができたなら「メイン画面へ」をクリックします。
h. | メイン画面の操作方法
図4. メイン画面
1 | 右上のボタンをクリックすると「コンピュータ」「ソフトウェア」「情報の量と表現」「情報社会」の大項目を選んだことになります。
2 | その下の段の文字か本のアイコンをクリックすると、中項目を選んだことになります。
3 | 一番下の段には、上で選んだ項目の中にある画像ファイルが表示されています。クリックするとファイルを選んだことになり、左のスペースに画像が表示されます。ビデオのアイコンがついたファイルは動画です。
4 | 静止画像をクリックすると静止画が拡大して表示されます。元に戻すには静止画をもう一度クリックします。
5. | 画像の保管場所と保管方法の設定を変えるには、メニュー欄のファイルの項から「ファイル保管場所の確認」をクリックして、「画像データ保管場所確認」画面を表示させます。
6. | メニュー欄の「コピー」では表示されている静止画をクリップボードにコピーできます。ペイント等のほかのアプリケーションで「貼り付ける」ことができます。

トップ アイコン トップページへもどる

直線上に配置


謝辞

当初自分のところで使うために作ったソフトでしたが、WEBで公開したところギジュツドットコムの「G-Soft」に加えていただけることになりました。ソフトは実際に使ってもらえ、使う側からの意見や要望をもらえると、励みになりますし「自分の今ある技量の範囲でやろう」という安易な気持ちを払拭する契機にもなります。

「G-Soft」に加えていただく過程やまたその後使っていたく過程で、ギジュツドットコムを主宰されている長野県中野平中の村松浩幸さんをはじめ多くの方からご意見やアドバイスをいただきました。

その中で一番多かった要望は画像ファイルのダウンロードと保管方法についてでした。今回のバージョンでは、「素材集」が掲載されているウエブサイトでのフォルダ構成のままダウンロードして保管したファイルをそのまま使えるようにし、またこのソフトで閲覧するファイルだけをダウンロードする「ダウンロードツール」を作りました。うまくいっているかは使っていただく中で明らかになると思いますが、私にとってはとても良い勉強になりました。ありがとうございました。

今回専用のダウンロードツールを作りました。手作業でひとつひとつダウンロードしていたことを思い出すと、我ながらちょっと感動しました。
ダウンロードツールの作成には、北山洋幸著「はじめてのVisual　Basic6.0　インターネットプログラミング」（技術評論社）で勉強をし参考にしました。「まずは作ってみる」という叙述の仕方が気に入っています。

今回のバージョンアップで最も多くの「注文」をしてくれたのは教育情報学を学んでいる学生さんである小山田誠さんでした。小山田さんには年末・クリスマスとお忙しい中にもかかわらずバグ取りを快く引き受けていただき、私の凡ミスに根気よく付き合っていただき、さらに多くのアドバイスをいただきました。この場を借りて御礼申し上げます。

諸情報

開発言語　Ｖｉｓｕａｌ　Ｂａｓｉｃ　V6.0（ＳＰ5）　Ｐｒｏｆｅｓsｉｏｎａｌ　Ｅｄｉｔｉｏｎ
開発環境　Windows XP Home Edition
テスト　　　　Windows 98、ＸＰ　各メーカー８台
（９５、Ｍｅ、ＮＴでは動作確認をしていません）

御意見御感想等をお聞かせください。

著作権者
谷村　康行
Ｅ-ｍａｉｌ　SNA50130@nifty.com

http://allisvanity.hp.infoseek.co.jp/Soft/VOPC.htm
http://homepage2.nifty.com/SUBAL/BCindex.htm

勤務先　日本航空専門学校　航空技術工学科
お問い合わせ等はメールでお願いします。
トップ アイコン トップページへもどる

直線上に配置